On Wednesday 19 October 2011 14:05:50 Mike Frysinger wrote: > now that we have "in_iuse" in eutils.eclass (with all the caveats), i'll be > adding huse: > huse() { > in_iuse $1 || return 1 > use $1 > } actually, after posting this, "iuse" is probably a better name. "huse" came up because the code constructs i was using before was like: has foo ${IUSE} && use foo && ..... which collapses into: h[as foo ${IUSE} && ]use foo && ... huse foo && ... so new proposal for those who love 1 liners: iuse() { in_iuse $1 && use $1 || return 1 ; } -mike